Importing a Satellite Scan model

Importing a Satellite Scan model

Available with the Following Subscriptions: Standard, Premium, Enterprise

In this user guide article, you will learn how to bring Google Maps data into cmBuilder.

Use cases:

  • Increase the accuracy and quality of existing buildings
  • Import new terrain
  • Import an existing building for demolition planning

________________________________________________________

Initial Setup

We will need to install two free software and create a Google API account.

1. Download and install Blender at their official website: https://www.blender.org/ 

  • It is strongly recommended to use the latest stable version of Blender

2. Download the Blosm Add-on at their website: https://prochitecture.gumroad.com/l/blender-osm 

  • A donation value is required but can be set to Zero and the final download is a ZIP file.

3. Open Blender and install the add-on by clicking on Edit (1) > Preferences (2) > Install (3) and select the downloaded zip file (4).

Blender-install_downloaded_zipfile.webp

4. Once the add-on is installed, enable it by checking this box (1), setup a folder to save additional files (2), and click on “Get it!” on the Google 3D Tiles access token (3).

Blender-Google 3D Tiles access token.webp

 

5. Use the Add-on Developer instructions at section "Google 3D Tiles Key" to set create your API Key: https://github.com/vvoovv/blosm/wiki/Import-of-Google-3D-Cities#google-3d-tiles-key

6. IMPORTANT!!! Once you have created your API key, paste it in the dedicated field but remember to enable the Map Tiles API in the Google Platform: https://developers.google.com/maps/documentation/tile/cloud-setup#enabling-apis 

Importing a Map in Blender

Blender is a powerful modelling software that might need some familiarization to be used efficiently. There is a lot of material online but you can start with the official navigation instructions: https://docs.blender.org/manual/en/latest/editors/3dview/navigate/index.html

Here is the step-by-step instruction on how to use the Blosm add-on to import Google Maps into Blender:

1. Create a project in Blender and:

  • Delete the initial Camera, Cube and Light objects (1)
  • Use the shortcut “N” to open the side panel (2)
  • Click on the Blosm tab (3)
  • Select the Google 3D Tiles option (4)
  • Click on “Select” to open a browser tab with the area selection (5)

Blender-Blosm tab.webp

2. Follow the instructions on the side panel to copy your coordinates. Try to get the smallest possible area as the final 3D model will be bigger than the rectangle selection.

3. Paste the coordinates in the add-on (1), set the level of details to “buildings with more details” (2), turn on the additional settings (3) and click “Import” (4). Please note that a higher level of details will take longer to import.

4. It might take some time, but your area import will show up in the view and we need to apply some settings to view it correctly:

  • Zoom out to see the whole imported model
  • Click on the View tab and increase the “End” value to increase the field of view (10000 m to 100000 m should be enough).

  • Set the Viewport Shading to Material Preview to be able to see the textures in the model

5. The area generated is never going to be exactly as it was selected in the web browser window, but we can trim it to focus on a specific boundary.  If there are missing elements in the generated model, delete it and recreate it with a larger area selection in the web browser step.

Saving the imported map

**Before moving forward with any editing step, let's save the file and manage the textures path.**

1. Select File > Save As or just press CTRL+SHIFT+S to save the original import in a local folder

2. Select the 3D model and click on “Replace Materials” on the Blosm tools:

3. After saving, Select File > External Data > Unpack Resources > Use files in current directory. This will create a folder with all the texture files in your local folder.

4. Once the folder is created, Select File (1) > External Data (2) > Pack Resources (3). This step will reconnect all textures with a local mapping that can be exported.

Cleaning the imported map

The suggested initial edit is to remove the parts you don’t need from the 3D model and create an opening for the area of your project. Much can be done with this 3D model before importing it to cmBuilder; we will cover that in another set of instructions.

 In this tutorial, we will use the Edit Mode function to manually delete parts from the imported model but if you are interested in learning more, please search online for instructions on how to use the following features in Blender:

  • Boolean Operations
  • Knife Tool
  • Separate by Selection

To start, select the imported model and:

1. Select “Edit Mode” or press TAB to visualize all vertices of the 3D Model (1)

2. Toggle X-ray on to select all vertices inside your lasso select tool, regardless of whether they are behind other geometries (2)

3. Click on Z or press 7 on your numeric pad to activate a top-down orthographic view (3)

4. Hold Shift + Left-click to create a lasso selection, select the areas to be removed from the 3D model, Right-click and select “Delete Vertices”. You can also press “W” to use different selection tools.

5. Repeat this action to clean up your model, keeping just the relevant areas and creating an opening for the location of your project

6. IMPORTANT!!! Select Mesh (1) > Separate (2) > By Material (3) to split the model into smaller parts based on their textures. This is only needed when the model import in cmBuilder presents broken textures.

Exporting and uploading to cmBuilder

Save a copy of the Blender file to keep the original Blosm Import as a backup and follow these steps:

1. Click on File (1) > Export (2) > FBX (3)

2. Set the Path Mode to “Copy” (4)

3. Toggle Embedded Textures on (5)

4. Set Forward to “Y Forward” (6)

5. Save the model in a local folder and import it to cmBuilder following the standard steps on this UG page: 1.1 Import 3D Models

 

Was this article helpful?
2 out of 2 found this helpful

Comments

0 comments

Please sign in to leave a comment.

Articles in this section